POPS Performance Impact

Incident Report for OpenPM - S11

Resolved

Performance has been restored.
Posted Oct 27, 2025 - 14:16 EDT

Investigating

PatientOPS (POPS) is currently experiencing performance issues. Our engineers are working diligently to restore the speed of the application.
Posted Oct 27, 2025 - 14:11 EDT
This incident affected: POPS.